Help:Nuclide Mixtures++

From NucleonicaWiki
Jump to: navigation, search

Level: Intermediate, Advanced

Create html file for this document

Contents

Nuclide Mixtures++ Application

In this section we describe the Nuclide Mixture++ application and how such mixtures can be created, edited, uploaded, etc. For an overview of this application see Nuclide Mixtures. Nuclide Mixtures play a key role in Nucleonica - once mixtures have been created/imported they can be used in a variety of applications (e.g. Decay Engine++, Dosimery & Shielding++, e-Ship++, Gamma Spectrum Generator, neutron activation, etc.).

The Nuclide Mixtures++ application can be accessed from the main Nuclear Science application centre or from the Applications drop-down menu (shown below). Alternativley the Nuclide Mixtures++ application can be accessed via the applications or the nuclide mixtures quick links shown in the right hand column in the figure.

Various ways of accesing the Nuclide Mixtures++ application


My Mixtures

The My Mixtures tab contains a list of mixtures either created by the user or copied from the sample mixtures. Mixtures shown in bold have been copied from the Sample Mixtures. The last nuclide created/edited is shown at the top of the list highlighted. Just above this most recent mixture, there is a hyperlink create which allow the user to create a new nuclide mixture. By clicking on the Mixture header, the mixtures can be arranged in ascending / descending order alphabetically (indicated by the small white triangle). To the right of each nuclide mixture, the Date modified gives the date of the most recent modification of the mixture. By clicking on the Date modified header, the mixtures can be arranged in ascending / descending order (indicated by the small white triangle). By clicking on the disk icon in the Download column, the user can download the mixture in xml format. By clicking on the recycle bin icon in the Delete column, the user can delete the mixture.

At the bottom of the list, the total number of mixtures is given. The adjacent download icon allows the user to download ALL mixtures into a single xml file. This is useful for backup purposes or for sending nuclide mixtures to other users. The second icon should be used with care since it allows the user to delete all mixtures in the list.

To the left of the list of mixtures, there is a column Select which allows the user to check one or more nuclide mixtures. At the bottom of the mixtures list, the selected mixtures can be sent to a user contact by selecting a contact from the Send to my contacts drop down list. Additionally, the selected nuclides can also be deleted.

In the My Mixtures summary tab, a new column has been introduced which gives the nuclear data library (e.g. ENDF/B-VII.1, JEFF3.1, etc) used to create the Nuclide Mixture. Currently, the default nuclear data library is JEFF3.1. In future versions of Nucleonica, the user will have the possibility to select the nuclear data library.

Nuclide Mixtures++ user interface


Create/Edit

To edit any of the mixtures shown above, the user can either click on the mixture name or on the Create/Edit tab. A new tab window will open to show more details of the mixture and its components as shown below. In this tab, the user can see the name of the mixture together with a short description. Also shown are the half-lives, activities, masses, number of atoms, number of moles (atoms), mass ratio, mole ratio and the activity ratio, mass ratio (or mass fraction), and mole ratio (or mole fraction) of each component. The weight percent (%) and atom percent (%) are related to the mass and mole ratio by a factor 100.

Nuclide Mixtures++ edit tab


Each component of the mixture can be edited by directly clicking on the component. The new activities, masses, number of atoms or moles, can then be entered into the drop-down menus. Thereafter the mixture can be saved. Finally the number of significant figures in the nuclide mixture list can be changed (in the Options tab). This is sometimes necessary for example when the natural abundancies are used to specify the maount of a particular nuclide. Abundancies can have six or more significant figures.

Add a new Nuclide

A new nuclide can be added to the list by clicking on the add a "new Nuclide" link.

Add an new Element

A new Element can also be added (see section on Elements).

Rescaling

The rescaling feature allows to user to very simply rescale the input quantities to any other values. In the creation of a nuclide mixture for uranium, one could consider a total number of 100 atoms. The numbers of U238, U235, and U234 atoms are then given by the isotopic abundancies i.e. 99.2742, 0.7204, and 0.0054 respectively. If instead of 100 atoms (total), one would like to convert to say 25g uranium, this can be easily done by rescaling. By clicking on the "total" in the figure, the user can then change the total mass, activity, number of atoms or moles directly.

Generate a Random Mixture

A new feature – Generate Random Mixture – allows the user to creat a random mixture of 10 nuclides in a single operation. The feature allows for easy random generation of nuclide mixtures and is particularly useful for “stress testing” the various Nucleonica applications. By default each nuclide component contain 1 pMole of atoms.

Generate a random mixture


Radiations

A new Radiations tab has been introduced to show the “handling” properties for a mixture and its component nuclides. In particular, the gamma dose rate, the heat rate (isotopic power) and the neutron emission rate are given for each nuclide and the total rates for the mixture. The quantities shown in the table can be selected in the Options (next section). For more information on how the heat rates (isotopic powers) are calculated, see the glossary entries on Isotopic power and average decay energies.

Nuclide Mixtures++ Radiations tab


Options

The Option tab has been inroduced to allow users to choose the various quantities shown in the Radiations tab. In addition, the number of significant figues shown in the tables can also be changed (default value is 4).

Nuclide Mixtures++ Options tab


Upload

The import functionality of the mixture module was extended to CSV (Comma Separated Values) files. Until now, the import feature supported only the XML format produced by the download part of the module.


A CSV file consists of two main parts:

• A header line, which contains a title for each column of the following data grid

• A set of lines each of them containing a set of values described by the entries of the header line.


An import file for the nuclide mixture should contain exactly two columns:

• The nuclide name

• The nuclide quantity

Nuclide Mixtures++ Upload tab expand



Allowed File Formats

The nuclide name begins with the chemical symbol of the element followed by the mass number of the isotope. The chemical symbol and the mass number may be separated by a dash (-) or a single space but the delimiter can also be omitted, e.g.: Co-60, Cs 135, C14. If the nuclide is not in the ground state, its isomeric state should be specified by one of the letters (m, n, p, q, r, s, t, u, v) directly after the mass number without separator e.g. Ba137m, Tc-99m, or Eu 152n. The letters correspond to the isomeric states 1 to 9 where 0 means the ground state. In fact only the isomeric states 0 to 3 are used in Nucleonica.

  • The nuclide identifier has now been extended to include capital letters (e.g. NB-93M) and the so-called ZAID format (e.g. 92238) as shown in the figure above.
  • ZAID format: The MCNP6 suggestion for representing metastable isotopes can be used: adjust the AAA value using the following convention: AAA’=(AAA+300)+(m × 100), where m is the metastable level and m=1, 2, 3, or 4. For naturally occurring elements, AAA=000 is suggested, for example 008000 represents the element oxygen.


The nuclide quantity can be given in different units. The unit used in the import file should be indicated by the header of the second column as shown below where the quotation mark are not needed unless a field qualifier is used for each value:

• “Activity (Bq)”

• “Activity (Ci)”

• “Mass (g)”

• “Mole”

• “Atoms” or “Number of Atoms”

The import program checks (case insensitive) the header of the second columns for these values where spaces are not taken into account to determine the unit.


Value separator:

The values contained in the data lines as well as in the header line are separated by a delimiter. The characters below can be used as delimiter:

• comma (,)

• semi colon (;)

• colon (:)

• pipe (|)

• octothorpe (#)

• tabulator (character code 09)


Field qualifier:

In addition each value of the data lines and of the title line may be surrounded by a pair of so called field qualifier. A field qualifier can be an apostrophe (‘) or a quotation mark (“).

When a field qualifier is needed, it should be applied to each value in the file.


Decimal point and thousands separator:

The user can select the character used as decimal separator, a decimal point or a decimal comma, by the mean of a pair of radio buttons. If a comma is used as decimal separator, the program assumes the point is the thousands separator: the point will then be suppressed from the values and the decimal coma is replaced by a decimal point in order the numerical values can be processed correctly.


Note: If you csv datafile has a Totals row as the final entry, please remove this row before uploading.



Some typical running times

Typical running times for various applications listed below using nuclide mixtures with large numbers of nuclides:

Nuclides = 30,

Mass Activity Converter <1s

Decay Engine++ 10s

Dosimetry & Shielding++ 17s (no daughters), 20s (with daughters)

  • Gamma Spectrum Generator 80s

Cambio File Converter <5s

WESPA <7s


Nuclides = 65,

Mass Activity Converter <1s

Decay Engine++ 13s

Dosimetry & Shielding++ 18s (no daughters), 36s (with daughters)

  • Gamma Spectrum Generator 200s

Cambio File Converter <5s

WESPA <7s



Download

A nuclide mixture can be downloaded from the My Mixtures tab by clicking on the download icon. The downloaded file is in xml format i.e. it is a text file similar to html with tags. In the figure below, it can be seen that the xml file is easily read and understood and corresponds direclty to the information on the mixture in the Edit grid. For each nuclide component in the mixture the material index, the mass (in g), half-life (in s) and activities (in Bq) are given.

In addition to downloading the mixture in xml format, it can also be downloaded in Excel or csv formats using the download button in the Create/Edit tab.

Download



Sample Mixtures

The Sample Mixtures tab contains a list of pre-defined sample mixtures. By transferring these mixtures to the users own My Mixtures (by clicking on Send to my mixtures), sample mixtures are immediately available for testing.

Nuclide Mixtures++ Sample Mixtures tab


Creating Nuclide Mixtures

A new mixture can be created by clicking on the "create" link in My Mixtures tab. Thereafter, the Edit tab window will be shown with no content. The user should then specify name of the mixture, provide a brief description, and then add the nuclide components. After each operation the mixture should be saved to avoid losing information.

A new nuclide is added to the nuclide mixture by selecting the desired nuclide in the Element and Mass combo boxes, entering the desired quantity (mass, activity, number of atoms, or moles) and clicking the update button. Similarly, the nuclide can be removed by clicking on the delete icon. All nuclides can be removed by clicking on the delete icon adjacent to the Total quantity in the nuclide column.

My First Mixture: A mixture of U232 and Co60

In the following example a new nuclide mixture consisting of U232 and Co60 is created. The first step is to create the nuclide mixture by clicking on "create" in the My Mixtures tab. Thereafter the name "U232+Co60" of the mixture is typed into the Name field. In the Description field, the text "1g (total) U232 and Co60 mixture" is used.

In the "Element" box the user can select the first element of the mixture – “Co” for cobalt. Following selection of the element, the isotope can be selected from the "Mass" box i.e. in this case “60”. An input quantity of 0.6 g is specified. The same procedure is followed for 0.4g U232.

Creating a nuclide mixture containing U232 (0.4g) and Co60 (0.6g)


Decay Calculations

The newly created mixture can be used in many of the Nucleonica applications. In this section we demonstrate using this new mixture in the decay and dosimetry & shielding applications.

On launching the Decay Engine++ application, the window shown below appears. The default time in the calculation is ten half-lives of the nuclide component with the shortest half-life (in this case Co60, halflife 5.26 y). On pressing the "Start" button, the results are shown.

Decay Engine interface showing the default input values for the U232+Co60 mixture.


Decay engine results for initially 1 g of the mixture U232+Co60 over a period of 52 years


Dosimetry & Shielding

If the dosimetry and shielding application is selected, the window shown below appears. The default activity is seen to be the total activity of the U232+Co60 mixture. The default source detector distance is 1m. On clicking the "Start" button, the results window is obtained.


Dosimetry & Shielding interface showing the default input values for the U232+Co60 mixture and the summary output


Dosimetry & Shielding


Complex Nuclide Mixtures

In this section, it is shown how complex nuclide mixtures can be created.

Zirconium hydride, ZrH1.6

In particular we consider a fuel element for a research reactor with the composition:

Fuel element composition: 8.5% wt 20% enriched U-235, mixed with 91.5%wt ZrH1.6.


Step 1: The element Zr consists of 5 stable (or almost stable) isotopes with the following abundancies: Zr-90 = 51.45, Zr-91 = 11.22, Zr-92 = 17.15, Zr.94 = 17.38, Zr-96 = 2.80. In this first step we create, using the nuclide mixtures application, 100 atoms of Zr with 51.45 atoms of Zr-90, 11.22 atoms of Zr-91, etc. We now have 100 atoms of Zr.

100atoms Zr plus 160 atoms H (composition ZrH1.6)


To this we have to add 160 atoms of H-1 (we neglect H-2 deuterium). This results in a mixture of ZrH1.6 with 100 atoms Zr and 160 atoms H. We now rescale this to 91.5 g. To do this click on Total in the Nuclide column. Now change the 260 atoms to 91.5 g.and update. Save the mixture.


Step 2: Create a new mixture containing 100g of 20% enriched uranium using:


U-238 = 80 g, U-235 = 20 g,(neglect U-234)

100 g enriched (20%)uranium


Now rescale this result from 100 g to 8.5 g total mass using the method described above. Save the mixture. Make a note of the masses of U-235 (1.7g) and U-238 (6.8g).


Step 3: Open the previously created mixture of ZrH and add the masses of U-235 and U-238. You will then see that the total mass is 100 g.

100 g fuel element containing 20% enriched uranium and ZrH


Zircaloy-4

Using the above procedure even more complicated mixtures can be created. One such example is Zircaloy-4 (Zyr-4) which is used as a cladding material in nuclear power reactors.

Composition of Zircaloy-4 (gram/kg Zyr-4): H (0.025),B (0.0005), C (0.27), O (1.6), Mg (0.02), Al (0.075), Si (0.12), N (0.065), Ti (0.05), Cr (1.3), Mn (0.05), Fe (2.4), Co (0.02), Ni (0.07), Cu (0.05), Zr (976.559), Mo (0.05), Cd (0.0005), Sn (17), Hf (0.1), W (0.1), U (0.075)

Zircaloy-4 mixture


In this mixture shown, the Zircaloy contains (for simplicity) only the elements Zr, Sn, Fe, Cr, O which accounts for 99.98% of the total mass (Zr, 5 isotopes; Sn, 10 isotopes; Fe, 4 isotopes; Cr, 4 isotopes; O, 3 isotopes (total 26))

This mixture can then, for example, be irradiated in a power reactor (using webKORIGEN in the Flux mode) to determine the activation products. Further decay calculations can then be performed with the module Decay Engine for Large Data Sets (the most recent results from webKORIGEN are stored in the sample Nuclide Set in this module).



Creating Element and Compound Mixtures

Creating nuclide mixtures for compounds such as ZrH1.6 or Zyr-4 (see previous section) can be a time consuming process. For this reason, the Nuclide Mixtures applications has been extended such that elements can be added directly. In this section we show how elements mixtures can be created.

Natural Uranium (metallic)

In the previous section - Complex Nuclide Mixtures - it was shown that to create natural uranium, three nuclides have to be added. By adding, the element uranium, however, with its natural abundancies, only one steps is involved i.e. - to add the element uranium. This is shown in the figure below. From the Edit tab, the user must first select add new Element. The element uranium (1 mole) is then added (shown in the main figure). The mixture can then be rescaled to any other quantity. To see the nuclide components, the user should click on add Nuclides as shown in the inset.

Natural Uranium.


Natural Uranium Dioxide

In the previous section - Complex Nuclide Mixtures - it was shown that to create natural uranium dioxide, six nuclides have to be added (three uranium and three oxygen nuclides). By adding, the elements uranium and oxygen, with their natural abundancies, only two steps are involved - one to add the element uranium and one to add the element oxygen. This is shown in the figure below. From the Edit tab, the user must first select add new Element. The elements uranium (1 mole) and oxygen (2 moles) are then added (shown in the main figure). The mixtures can then be rescaled to any other quantity. To see the nuclide components, the user should click on add Nuclides as shown in the inset.

Natural Uranium Dioxide.


Zirconium Hydride ZrH1.6

In the previous section - Complex Nuclide Mixtures - it was shown that to zirconim hydride (ZrH1.6), seven nuclides have to be added (five zirconium and two hydrogen). By adding, the elements zircomium and oxygen, with their natural abundancies, only two steps are involved - one to add the element zirconium and one to add the element hydrogen. This is shown in the figure below. From the Edit tab, the user must first select add new Element. The elements zirconium (1 mole) and hydrogen (1.6 moles) are then added (shown in the main figure). The mixtures can then be rescaled to any other quantity. To see the nuclide components, the user should click on add Nuclides as shown in the inset.

Zirconium Hydride ZrH1.6


Zircaloy-4 (Zyr-4)

Zircaloy-4 (Zyr-4) is used as a cladding material in nuclear power reactors. The composition of Zircaloy-4 (gram/kg Zyr-4) is as follows: H (0.025),B (0.0005), C (0.27), O (1.6), Mg (0.02), Al (0.075), Si (0.12), N (0.065), Ti (0.05), Cr (1.3), Mn (0.05), Fe (2.4), Co (0.02), Ni (0.07), Cu (0.05), Zr (976.559), Mo (0.05), Cd (0.0005), Sn (17), Hf (0.1), W (0.1), U (0.075). In this example, a mixture is created using only the main 5 elements (which accounts for 99.8859 of the mass).

In the previous section - Complex Nuclide Mixtures - it was shown that to create zircaloy-4, twenty six nuclides have to be added (five zirconium and two hydrogen). By adding, the elements zirconium, tin, iron, chrome and oxygen, with their natural abundancies, only five steps are involved. This is shown in the figure below. The mixture can then be rescaled to any other quantity. To see the nuclide components, the user should click on add Nuclides as shown in the inset.

Zircaloy-4 (Zyr-4)


Personal tools
nucleonica premium
Karlsruhe Nuclide Chart